Apple Online Store: Yosemite 10.10.5 minimum required

Apple raises the security requirements in its own online shop a bit.

As macotakara has found, Apple issues an error message when accessing the online store with an OS X version older than 10.10.5 Yosemite or using a Safari version older than 10.1.2. It is even suggested to download another browser.

But maybe your Mac also allows a newer version, on many models from 2008 on you should at least possible to run 10.11. If you have such a model you can even install 10.14 Mojave with little effort – here we do explain how that works.

Comments are closed.